Low prices, no fees & free shipping. Seen it cheaper?
Key Details:
- Model: 1301009
- Part #: SN000832
- Warranty: 1 Year
- Brand: Yealink
Ask Our Experts:
Yealink SIP-T73W Business IP Phone 2.8 Inch Color Display with Backlight
The T73W IP phone is an all-in-one business phone that enables excellent voice communications and extended functions. Equipped with Hall switch technology, the T73W provides you with a quieter office environment. The redesigned appearance of Yealink's new T73W makes the phone more fashionable, thinner, and more in line with modern aesthetic standards. The T73W supports 12 SIP account registrations and has a 2.8-inch color display with a backlight and an EXP55 expansion station. Combined with Yealink 's ultra-high-definition voice technology, the T73W provides you with excellent audio quality and clear voice communications. When making calls, the phone responds faster and more responsively. Built-in Bluetooth 5.0 module and dual-band 2.4G/5G Wi-Fi 6 modules, allowing you to keep up with the latest technology and gain an advantage in the future wireless era. In addition, a built-in USB port realizes the functions of a USB headset and USB recording, and you can choose freely according to your needs. The T73W adopts a TEE hardware encryption solution, providing you with a more secure storage experience. At the same time, it improves the performance of the phone, bringing you more flexible interoperability and a better collaboration experience. The T7X series better builds the Yealink ecosystem and is compatible with more Yealink headsets. The phone supports configuring and upgrading headsets through LCD and supports Yealink headsets with a wearing detection function for intelligent channel switching.
HD Audio Ultra-High-Definition Sound Quality:
The sound quality of Yealink T7X series phones is higher definition and perfect, making communication easier. Yealink combines cutting-edge hardware and software with broadband technology to achieve the best acoustic performance. Its hearing aid compatible (HAC) handset helps people with hearing loss hear sounds more clearly.
High Security and Compatibility:
T73W adopts the latest TLS/SSL network security technology. It is widely compatible with leading soft switch vendors, such as 3CX, Broadsoft, and Broadworks. In addition, T73W supports a dual system function, which can back up your phone system in advance to avoid system crashes caused by upgrade failure, thus providing you with enterprise-level system protection. T73W supports the security center function, allowing users to decide whether to connect the phone to the device management platform/service and what private data is allowed to be reported.
Customizability and Scalability:
T73W supports five-page turning and up to 40 programmable buttons. In addition, T73W can be cascaded to up to 3 expansion units. 234 programmable buttons effectively save operation time and achieve efficient office work.
Easy Installation and Deployment:
You can use Yealink RPS (Redirection and Provisioning Service) and Boot mechanisms to enable fast and efficient deployment. Users do not need to configure and upgrade the phone manually. They only need to power on and connect to the Internet, and the phone will be automatically deployed, saving a lot of time and cost, and achieving true "zero-touch provisioning". In addition, Yealink T7X series IP phones all use the same firmware, which greatly simplifies management and maintenance costs and facilitates management, upgrades, and maintenance.
Wireless Data Transmission:
Yealink T73W has a built-in Bluetooth 5.0 module, supports Bluetooth headsets, and can connect to mobile phones via Bluetooth for phone address book matching. At the same time, in order to adapt to the upcoming 5G Wi-Fi era, T73W has built-in dual-band Wi-Fi 6 (Dual band). 5G Wi-Fi has better anti-interference and faster speed, allowing you to be one step ahead in the busy data torrent. In addition, T73W can be used with the Yealink video conferencing soft terminal to share the content on the computer with the remote end, giving you the ultimate content-sharing experience.
TEE Hardware Encryption Solution:
T73W uses the TEE hardware encryption solution, which can provide you with a more secure data storage experience.
Audio Features:
- HD voice: HD handset, HD speaker
- Hearing aid compatible (HAC) handset
- Acoustic Shield
- Smart Noise Filtering
- Audio codec: AMR-WB (optional), G.722
- Narrowband codec: AMR-NB (optional), PCMU (G.711μ), PCMA (G.711A), G.723.1, G.729, G.729A, G.729B, G.729AB, G.726, iLBC
- DTMF: In-band, Out-of-band (RFC 2833) and SIP INFO
- Full-duplex hands-free speakerphone with AEC
- VAD, CNG, AEC, PLC, AJB, AGC
User Interface:
- LCD screen
- 2.8-inch 320x240 resolution screen
- Supports wallpaper and screen saver
- Incoming calls and unread message indicator lights
- Intuitive user interface
- Supports multi-language operation interface
- Caller ID display of name, number, and photo
- Supports both dark and light themes
Phone Features:
- 12 VoIP accounts
- One-touch speed dial, hotline, mute, DND
- Call hold, call forward, call waiting, call transfer
- Group listening
- Emergency call
- Redial, call return, auto answer
- 5-way conferencing
- Direct IP call without SIP proxy
- Ring tone selection/import/delete
- Set date/time manually or automatically
- Dial plan, action URL/URI
- XML Browser, XML Push
- RTCP-XR (RFC3611)
- Custom DSS Key
- Accessibility features
Directory:
- Local phonebook up to 1000 entries
- Blocklist
- XML/LDAP remote phonebook
- Google Contacts
- Smart dialing
- Contacts search/import/export
- Call history: All records/dialed/received/missed/forwarded calls
IP-PBX Features:
- Busy Lamp Field (BLF), Bridged Line Appearance (BLA)
- Anonymous call, anonymous call rejection
- Message Waiting Indicator (MWI)
- Voice messages, call parking
- Call pickup, intercom, multicast
- Music on hold
- Call recording, mobile office, chief assistant
- Server-based recording function
- Visual mailbox user interface
Display and Indicator:
- LED for call and message waiting indication
- Account status information red and green dual color indicator light
- Intuitive user interface with icons and soft keys
- Multilingual user interface
- Caller ID with name and number
- Screensaver
- Power saving
Feature keys:
- 8 line keys with LED keys (up to 40 DSS keys, 5 pages)
- 4 touch buttons: message, headset, mute, pagination(mute/headset/pagination button with indicator light)
- 4 function keys: call hold, call transfer, redial, hands-free
- 2 volume control keys
- 6 navigation keys
Interface:
- Dual Gigabit Ethernet ports
- 1 x USB 2.0 interface (phone side): USB flash drive, Connecting a USB headset, Connecting to the color screen expansion station, Wireless Headset Adapter EHS40
- 1 x security keyhole
- 1 x RJ9 (4P4C) handset interface
- 1 x RJ9 (4P4C) headset jack
- 1 x 5V power port
- USB interface (compatible with 2.0)
- Support USB or Bluetooth connection to Yealink CP900/CP700 and UH38, USB connection to UH34/UH36/UH37
Management:
- Configuration: browser/phone/auto-provision
- Auto-provision via FTP/TFTP/HTTP/HTTPS for mass deployment
- Auto-provision with PnP
- Broadsoft device management
- Zero-Sp-Touch, TR-069
- Phone lock for personal privacy protection
- Reset to factory, reboot
- Package tracing export, system log
- Support Yealink Device Management Platform (YDMP/YMCS)
Network and Security:
- Built-in Dual-Band Wi-Fi: Network standard: IEEE802.11a/b/g/n/ac/ax, Frequency band: 2.4GHz/5.0GHz
- Built-in Bluetooth 5.0:
- IPv4/IPv6
- SIP v1 (RFC2543), v2 (RFC3261)
- Call server redundancy supported
- NAT traversal: STUN mode
- Proxy mode and peer-to-peer SIP link mode
- IP assignment: static/DHCP
- HTTP/HTTPS web server
- Time and date synchronization using SNTP
- UDP/TCP/DNS-SRV(RFC 3263)
- ARP, ICMP
- QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP
- Support SRTP protocol
- Transport Layer Security (TLS 1.3)
- HTTPS certificate manager
- AES encryption for configuration file (AES256)
- Supported authentication mechanisms: MD5/SHA1/SHA224/SHA256/SHA384/SHA512
- OpenVPN, IEEE802.1X, L2TP VPN
- LLDP/CDP/DHCP VLAN, ICE
- WPA2/WPA3
- Secure boot
- GARP (Generic Attribute Registration Protocol)
- TEE hardware encryption solution
Other Physical Features:
- Operating environment humidity: 5% - 90%
- Operating temperature: -10 to +45 ° C (+14 to 113 ° F)
- Storage temperature: -30 to 70℃
- Supports PoE power supply (IEEE 802.3af ), class 2
- Power adapter (optional): AC 100-240V input, DC 5V/2A output
- USB output current: 5V/500mA
- Power consumption (PSU): 1.30 W-1.48 W
- Power consumption (PoE): 1.368 W-1.832 W
- Dimension (WxDxHxT): 209.0 x 167.5 x 214.8 x 53.4 mm
- Yealink T73W IP phone
- Handset with handset cord
- Ethernet Cable (2m CAT5E UTP Cable)
- Stand
- Quick Start Guide
Similar Items
Why Buy From Us
Secure Payments
Pay securely via credit card, debit card, Apple Pay, Google Pay & online banking. We use Windcave as our payment provider, offering the highest level in payment security.
Fast, Same Day Dispatch
Our team check & process orders every few minutes, with items typically shipped within hours. Our aim is to dispatch orders same working day.
Free Delivery Offered
We offer free signature courier delivery across NZ for most our items. NZ Post & NZ Couriers are our main courier providers.
Official NZ Warranties
All our products are brand new, direct from the official NZ suppliers. That means genuine products backed with NZ warranties.
Insured & Tracked Delivery
Items are sent on a signature courier delivery service. Packages are tracked & insured so in the event of an issue, you are covered. More details.
100% NZ Owned for 20+ Years
Based in Auckland, New Zealand, we are one of NZ's biggest & most trusted online tech stores, supplying IT & office supplies to over 200,000 Kiwi customers.
What our customers say
Ordered late Wednesday night, and arrived midday thursday. Very pleased with the product.
From Mt Albert
Emails were answered quickly and efficiently. Friendly and efficient service. Great pricing.
From Birkenhead
Immediate processing and speedy delivery arranged to rural North Island. Most impressive and very much appreciated.
From Te Kaha